提供7*24专业Sybase数据库远程及现场技术支持,Sybase ASE及Sybase SQL Anywhere数据库修复服务,
请联系电话: (微信),QQ: 289965371!
We supply technical support for Sybase ASE and Sybase SQL Anywhere, also have many years of experience in recovering data from damanged Sybase devices.
Please contact us:
Phone:
Wechat: 13811580958
QQ: 289965371 联系我们获取数据库技术支持!
Email: 289965371@qq.com
扫描下方微信,联系我们:
扫描雨翰数据恢复官方微信获取专业数据库恢复服务

 

随着Sybase被完全整合到SAP下,Sybase原来的支持网站被SAP Support Portal取代。
只有购买了SAP服务的用户才能使用账号登录SAP Support Portal进行介质下载、补丁升级、报Incident等。
目前,原Sybase所有产品(包括:Adaptive Server Enterprise、Sybase IQ、Replication Server、PowerDesigner等)的官方手册仍然可以从https://infocenter.sybase.com/help/index.jsp进行浏览或下载。暂不清楚该网站https://infocenter.sybase.com/help/index.jsp何时会被完全迁移到SAP Support上!
Sybase官方手册英文版有html和pdf两种格式,而中文版手册只有pdf一种格式。为了国内Sybase用户更方便、快捷地搜索Sybase常见产品的官方手册内容,特将中文版Sybase官方手册转为html格式!
Sybase产品官方手册中文版的html格式所有内容的版权归SAP公司所有!本博客站长是Sybase数据库的铁杆粉丝!

如有Sybase数据库技术问题需要咨询,请联系我!

  QQ :289965371 联系我们获取数据库技术支持!
  Email:

以下官方手册为ASE 15.7 ESD#2中文版:

  1. 新增功能公告 适用于 Windows、Linux 和 UNIX 的 Open Server 15.7 和 SDK 15.7
  2. 新增功能摘要
  3. 新增功能指南
  4. ASE 15.7 发行公告
  5. 配置指南(windows)
  6. 安装指南(windows)
  7. 参考手册:构件块
  8. 参考手册:命令
  9. 参考手册:过程
  10. 参考手册:表
  11. Transact-SQL® 用户指南
  12. 系统管理指南,卷 1
  13. 系统管理指南,卷 2
  14. 性能和调优系列:基础知识
  15. 性能和调优系列:锁定和并发控制
  16. 性能和调优系列:监控表
  17. 性能和调优系列:物理数据库调优
  18. 性能和调优系列:查询处理和抽象计划
  19. 性能和调优系列:使用 sp_sysmon 监控 Adaptive Server
  20. 性能和调优系列:利用统计分析改进性能
  21. 程序员参考 jConnect for JDBC 7.0.7
  22. Adaptive Server Enterprise 中的 Java
  23. 组件集成服务用户指南
  24. Ribo 用户指南
  25. 内存数据库用户指南
  26. Sybase Control Center for Adaptive Server® Enterprise
  27. 安全性管理指南
  28. 实用程序指南

 


< 上一个 | 内容 | 下一步 >

内存数据库和宽松持久性数据库的限制 ‌ ‌ ‌

内存数据库和宽松持久性数据库包括下列限制:

• Cluster Edition 当前不支持内存数据库、宽松持久性数据库、模板数 据库或进行最少日志记录操作的 DML。

• Replication Server 当前不支持内存数据库或将持久性设置为

no_recovery 的数据库的复制。

• 不能将内存数据库用作存档数据库。 Sybase 建议您不要将内存数据 库用作空数据库。

• 内存数据库不支持使用兼容模式进行查询。在 Adaptive Server 中, 请仅对常规磁盘驻留式数据库表使用兼容模式。有关启用兼容模式 的信息,请参见 《迁移技术指南》。


如果您已经启用了兼容模式并且查询涉及到内存数据库中的表,则 Adaptive Server 会使用 “受限兼容模式”恢复到本机 15.0 版查询优 化程序和执行引擎。通常情况下,此模式会产生与 Adaptive Server 12.5 版本中的计划类似的查询计划。如果您注意到性能下降, Sybase 建议您对此查询禁用兼容模式。

• 您不能在用于增加数据库大小的同一命令中更改内存数据库或低持 久性数据库的持久性或日志记录级别。

• 在使用 alter database 命令更改数据库的 durability 或 minimal_logging 属 性时,该命令会自动将该数据库置于单用户模式,而如果该命令无 法获得对数据库的独占访问权,该命令就会失败。为了避免失败, 请在运行 alter database 之前手动将该数据库置于单用户模式。

• 内存数据库和宽松持久性数据库无法参与分布式事务。

• 内存数据库和宽松持久性数据库无法协调涉及到具有完全持久性的 数据库的多数据库事务。如果您执行的系统过程在您从内存数据库 或宽松持久性数据库运行存储过程时执行事务性更新,则会出现以 下错误:

Msg 3952, Level 16, State 2: Procedure 'sp_XX', Line 258:

Command not allowed. You cannot start a multidatabase operation in database 'master'

after starting the master transaction in 'imdb1' as it may render the database 'master' unrecoverable.

运行系统过程:

a 从完全持久性数据库中执行该系统过程。例如,若要在 master

中运行 sp_XX,请输入:

use master go

exec sp_XX

b 使用以下格式从当前数据库 (内存数据库或宽松持久性数据 库)中引用该存储过程:database_name.owner. sp_name。

例如,若要在 imdb_1 内存数据库中运行 sp_XX,请输入:

use imdb_1 go

exec master.dbo.sp_XX

• 在内存数据库中,您无法使用代理表或数据库映射到其它内存数据 库或磁盘驻留式数据库对象。

• 在磁盘驻留式数据库中,您无法使用代理表或数据库映射到内存数 据库或表。


已更改的系统过程


表 1-3 列出了已经更改以支持内存存储高速缓存、内存设备和内存数据 库的存储过程。 ‌

表 1-3:为内存数据库更改的系统过程

image

系统过程 注释

sp_addsegment 已更新以管理内存数据库中的空间。

sp_addthreshold 已更新以管理内存数据库中的空间。

sp_bindcache 您无法将对象或数据库绑定到内存存 储高速缓存,并且无法将内存数据库 或内存数据库中的对象绑定到任何高 速缓存。

sp_cacheconfig 创建、删除内存存储高速缓存或扩大 其大小。

sp_cachestrategy prefetch 和 MRU 参数不适用于内存数 据库中的表和索引。

sp_dbextend 对于内存数据库,当前不支持自动数 据库扩展。

sp_deviceattr directio 和 dsync device 属性不适用于 内存设备。

sp_diskdefault 不能使用 sp_diskdefault 将内存设备指 定为缺省设备。

sp_downgrade 支持将包含内存数据库或宽松持久性 数据库或包含使用模板或最少日志记 录的数据库的 Adaptive Server 降级到 以前的版本。

sp_dropdevice 删除从内存存储高速缓存创建的内存 设备。

sp_dropsegment 已更新以管理内存数据库中的空间。

sp_dropthreshold 已更新以管理内存数据库中的空间。

sp_extendsegment 已更新以管理内存数据库中的空间。

sp_help 报告表的属性,例如最少日志记录 属性。

sp_helpcache 显示内存存储高速缓存的属性、在此 高速缓存中创建的内存数据库以及此 高速缓存中可用空间的详细信息。

sp_helpdb 报告数据库的属性,例如,持久性、 DML 日志记录级别、是否是内存数 据库、模板数据库 (如果有)的使用 或是否用作模板数据库。

sp_helpdevice 报告从内存存储高速缓存创建的内存 设备属性。


image

系统过程 注释

sp_modifythreshold 已更新以管理内存数据库中的空间。

sp_plan_dbccdb 为内存数据库中的 checkstorage 执行 设置 dbccdb。

sp_poolconfig 内存数据库不支持大型 I/O 缓冲池。

sp_post_xpload 支持内存数据库的跨平台操作。

sp_tempdb 支持内存临时数据库的登录名或应用 程序绑定。

sp_unbindcache、 sp_unbindcache_all 不能从宿主内存存储高速缓存中解除

对象与内存数据库本身的绑定。




--------------------------------------华丽的分割线-------------------------------------------------------------------------

Sybase SQL Anywhere数据库恢复工具ReadASADB:

之前就已经研发成功了能够从Sybase SQL Anywhere的DB文件中恢复数据的工具: ReadASADB。
此工具支持ASA v5.0, v6.0, v7.0, v8.0, v9.0, v10.0, v11.0, v12.0, v16.0, v17.0等版本。
能够从损坏的SQL Anywhere数据文件(.db)和UltraLite数据文件(.udb)上提取数据的非常规恢复工具。
恢复Sybase SQL Anywhere的工具在国内处于领先水平。

Sybase SQL Anywhere数据库恢复工具ReadASADB功能
能够从损坏的SQL Anywhere数据文件(.db)和UltraLite数据文件(.udb)上提取数据的非常规恢复工具
  1. 适用于所有的SQL Anywhere版本    包括:5.x,6.x,7.x,8.x,9.x,10.x,11.x,12.x,16.x,17.x
  2. 适用于所有的UltraLite版本
  3. 能够恢复出来表结构和数据
  4. 能够恢复自定义数据类型
  5. 能够恢复存储过程等对象的语法
  6. 能够导出到目标数据库
  7. 能够导出到SQL文件并生成导入脚本
  8. 支持多种字符集,包括:cp850、cp936、gb18030、utf8等
  9. 能够恢复未加密或者简单加密类型的数据
  10. 简单易用
  11. 限制:不支持AES加密的数据文件
请参考:研发成功了从Sybase SQL Anywhere的DB文件上恢复数据的工具
            SQL Anywhere数据库非常规恢复工具ReadASADB使用介绍

Sybase SQL Anywhere数据库恢复工具ReadASADB适用场景

各种误操作:

  1. 误截断表(truncate table)
  2. 误删除表(drop table)
  3. 错误的where条件误删数据
  4. 误删除db或log文件
  5. 误删除表中的字段

Sybase SQL Anywhere数据库恢复工具ReadASADB的应用场景:

1.因为物理磁盘故障、操作系统、系统软件方面或者掉电等等原因导致的Sybase SQL Anywhere数据库无法打开的情况;
2.误操作,包括truncate table,drop table,不正确的where条件导致的误删除等;
Sybase SQL Anywhere无法打开时,比较常见的错误是:Assertion failed。
如:
1、Internal database error *** ERROR *** Assertion failed:201819 (8.0.1.2600) Checkpoint log: invalid bitmap page -- transaction rolled back
2、Internal database error *** ERROR *** Assertion failed:201819 (8.0.1.2600) Page number on page does not match page requested -- transaction rolled back
3、Internal database error *** ERROR *** Assertion failed:200502 (9.0.2.2451) Checksum failure on page 23 -- transaction rolled back
4、File is shorter than expected
5、Internal database error *** ERROR *** Assertion failed: 201116 Invalid free list index page found while processing checkpoint log -- transaction rolled back
6、*** ERROR *** Assertion failed: 51901 Page for requested record not a table page or record not present on page
7、*** ERROR *** Assertion failed: 201417 (7.0.4.3541) Invalid count or free space offset detected on a table page
8、Internal database error *** ERROR *** Assertion failed: 201425 (8.0.3.5594) Invalid count or free space offset detected on a free list page -- transaction rolled back.
9、Internal database error *** ERROR *** Assertion failed: 100702 (8.0.1.2600) Unable to modify indexes for a row referenced in rollback log -- transaction rolled back


-------------------------------------------------------------------------------------------

Sybase ASE数据库恢复工具READSYBDEVICE:

一个不依赖数据库管理系统、直接从Sybase数据库设备文件上提取数据的业内领先的恢复工具!
能够从损坏的Sybase ASE设备文件(.dat)上提取数据的非常规恢复工具。

Sybase ASE数据库恢复工具READSYBDEVICE的主要功能:

  1. 被勒索病毒加密数据文件及备份文件情况下的恢复;
  2. 系统崩溃只剩下数据文件的情况下的恢复,甚至数据库文件不存在而只有损坏的备份文件情况下的恢复;
  3. 因断电、硬盘坏道等造成数据库文件损坏情况下的恢复;
  4. delete数据恢复、误update数据恢复、误删除表(drop)恢复、误truncate表恢复 等;
  5. 各种Sybase内部系统表损坏、索引错误的修复;
  6. master数据库损坏而无法正常运行情况下的恢复;
  7. Sybase数据库被标记为可疑,不可用等情况的恢复;
  8. Sybase数据库中数据文件内部出现坏块情况下的恢复;
  9. Sybase数据库无数据文件但有日志文件的情况下的恢复;
  10. Sybase数据库只有数据文件无任何日志文件的情况下的恢复;
  11. Sybase数据文件被误删除情况下的碎片提取恢复;
  12. 磁盘阵列上的Sybase数据库被误格式化情况下的数据库恢复;
  13. 数据库sysobjects等系统表损坏无法正常应用情况下的恢复;
  14. Sybase数据库还原数据库出现失败情况下的恢复;
  15. Sybase数据库只剩下损坏的备份文件情况下的恢复。

Sybase ASE数据库恢复工具READSYBDEVICE支持的版本:

Sybase ASE 11.0.x,11.5.x,11.9.x,12.0.x,12.5.x,15.0.x,15.5.x,15.7.x,16.0.x


-------------------------------------------------------------------------------------------

SQL Server数据库恢复工具SQLRescue:

一个不依赖数据库管理系统、直接从SQL Server数据库文件上提取数据的业内领先的恢复工具!
能够从损坏的SQL Server数据库文件(.mdf)上提取数据的非常规恢复工具。

SQL Server数据库恢复工具SQLRescue的主要功能:

  1. 系统崩溃只剩下数据文件的情况下的恢复,即无日志文件或者日志文件损坏情况下的恢复;
  2. 断电导致数据库文件损坏情况下的恢复;
  3. 硬盘坏道造成数据库损坏情况下的恢复;
  4. 数据文件内部存在坏页情况下的恢复;
  5. 企业管理器误删除数据表记录,管理软件误删除数据表记录的恢复;
  6. 并闩锁错误、格式化、误删除后导致软件不能使用的情况;
  7. 无法读取并闩锁页sysindexes失败情况下的修复;
  8. 数据文件被误删除情况下的碎片提取恢复;
  9. 系统表损坏、索引错误、误删除数据库表、删除记录的数据找回;
  10. master数据库损坏而无法正常运行情况下的恢复;
  11. 数据文件无法附加情况下的数据恢复;
  12. 数据库被标记为可疑,质疑,不可用等情况的恢复;
  13. 数据库sysobjects等系统表损坏情况下的恢复;
  14. 数据被误(drop、delete、truncate)删除表数据的恢复,误update后的数据恢复等;
  15. 还原时报一致性错误,错误823等情况下的数据恢复,各种错误提示的数据库文件修复;
  16. 数据库被误格式化等情况下的数据库恢复;
  17. 日志收缩造成数据库损坏情况下的恢复;
  18. 仅剩损坏的备份文件情况下的恢复。

SQL Server数据库恢复工具SQLRescue技术特点:

只要SQL Server数据库的数据文件存在,我们就有办法帮您从数据文件中找回重要数据。
  1. 从数据文件中直接恢复数据
  2. 不能附加时直接恢复数据并生成新的数据库
  3. 系统表损坏的数据库修复
  4. 快速修复SQL 823错误、连接中断错误

SQL Server数据库恢复工具SQLRescue支持的版本:

Microsoft SQL Server 7.0, 2000, 2005, 2008, 2008R2, 2012, 2014, 2016, 2017,2019。
+-------------------------------------华丽的分割线-------------------------------------------------------------------------