提供7*24专业Sybase数据库远程及现场技术支持,Sybase ASE及Sybase SQL Anywhere数据库修复服务,
请联系电话: (微信),QQ: 289965371!
We supply technical support for Sybase ASE and Sybase SQL Anywhere, also have many years of experience in recovering data from damanged Sybase devices.
Please contact us:
Phone:
Wechat: 13811580958
QQ: 289965371 联系我们获取数据库技术支持!
Email: 289965371@qq.com
扫描下方微信,联系我们:
扫描雨翰数据恢复官方微信获取专业数据库恢复服务

 

随着Sybase被完全整合到SAP下,Sybase原来的支持网站被SAP Support Portal取代。
只有购买了SAP服务的用户才能使用账号登录SAP Support Portal进行介质下载、补丁升级、报Incident等。
目前,原Sybase所有产品(包括:Adaptive Server Enterprise、Sybase IQ、Replication Server、PowerDesigner等)的官方手册仍然可以从https://infocenter.sybase.com/help/index.jsp进行浏览或下载。暂不清楚该网站https://infocenter.sybase.com/help/index.jsp何时会被完全迁移到SAP Support上!
Sybase官方手册英文版有html和pdf两种格式,而中文版手册只有pdf一种格式。为了国内Sybase用户更方便、快捷地搜索Sybase常见产品的官方手册内容,特将中文版Sybase官方手册转为html格式!
Sybase产品官方手册中文版的html格式所有内容的版权归SAP公司所有!本博客站长是Sybase数据库的铁杆粉丝!

如有Sybase数据库技术问题需要咨询,请联系我!

  QQ :289965371 联系我们获取数据库技术支持!
  Email:

以下官方手册为SAP IQ 16.0 SP03中文版:

  1. SAP Sybase IQ 简介
  2. 新功能摘要
  3. IQ 发行公告(linux)
  4. IQ 快速入门(unix)
  5. 安装和配置指南(linux)
  6. 管理:备份、恢复和数据恢复
  7. 管理:数据库
  8. SAP Sybase IQ 错误消息
  9. 管理:全球化
  10. IQ 许可选项指南
  11. 管理:装载管理
  12. IQ 迁移
  13. 管理:Multiplex
  14. 性能和调优指南
  15. IQ 编程
  16. 参考:构件块、表和过程
  17. 参考:语句和选项
  18. 管理:内存行级版本控制
  19. 管理:空间数据
  20. IQ 非结构化数据分析
  21. 用户定义的函数
  22. 管理:用户管理和安全
  23. 实用程序指南

 


< 上一个 | 内容 | 下一步 >

SAP Sybase IQ 停止处理或停止响应 ‌

您可以通过查看 SAP Sybase IQ 消息文件来检测导致服务器无响应的原因。


可能原因

服务器无响应的最常见原因包括:

• 磁盘空间不足

• 主缓冲区高速缓存或临时缓冲区高速缓存中的空间不足


操作

如果服务器在处理过程中或关闭过程中看上去倾向于无响应,使用 start_iq 命令行选项

-z 和 SAP Sybase IQ 数据库选项 QUERY_PLAN = 'ON' 在 SAP Sybase IQ 消息 (.iqmsg) 文件和服务器日志 (.srvlog) 文件中记录有用的信息。

除了记录此信息以外,还可以执行其它步骤,以确定问题的原因:

• 检查 SAP Sybase IQ 消息文件和服务器日志文件中是否存在 You have run out of space... 消息。如果 IQ 主存储库或 IQ 临时存储库已用尽,使用 CREATE DBSPACE 命令适当添加 dbspace。

将数据库选项 MAIN_RESERVED_DBSPACE_MB 和 TEMP_RESERVED_DB_SPACE_MB 设置为足够大的值,以便能够在 DDL COMMIT 或 CHECKPOINT 期间处理空间不足的情况;这一点也十分重要。几百 MB 应当足 够,但对于大型数据库,可以将这些选项设置得更高。

• 通过在操作系统级别对 CPU 使用情况进行几分钟监控,确定 SAP Sybase IQ 服务 器进程 (iqsrv16) 是否正在消耗 CPU 周期。记录此信息。如果 CPU 使用率更 改,则 SAP Sybase IQ 服务器进程应正在正常处理。


如果 SAP Sybase IQ 服务器 CPU 使用率正常,可以检查服务器正在做什么,即服 务器当前正在执行什么语句。

• 如果没有提示空间不足,请对新连接或现有连接使用 Interactive SQL,以便按指定 顺序收集以下信息。


表 22. 要收集的服务器无响应信息


命令

信息目的

SELECT db_name()

数据库名称

CHECKPOINT

检查点可以成功

sa_conn_properties ># sa_conn_properties.out

连接信息

sa_conn_info ># sa_conn_info.out

连接信息

sa_db_properties ># sa_db_properties.out

数据库属性信息

sa_eng_properties ># sa_eng_properties.out

服务器属性信息

sp_iqstatus ># sp_iqstatus.out

数据库状态信息

sp_iqconnection ># sp_iqconnection.out

连接信息

sp_iqtransaction ># sp_iqtransaction.out

事务信息


如果无法解决此问题,请联系 SAP Sybase 技术支持部门获取帮助。他们可以使用 您刚才收集的这些信息来帮助诊断问题。

• 服务器无响应时,可以通过在 $IQDIR16/logfiles 目录(Windows 64 平台上为

%ALLUSERSPROFILE\%\SybaseIQ\logfiles 文件夹,Vista 64 平台上为 C:

\ProgramData\SybaseIQ\logfiles)中创建名为 DumpAllThreads 或 dumpallthreads 的文件来为每个 SAP Sybase IQ 线程生成堆栈跟踪。 按照建议使用程序管理器或 start_iq 命令启动 SAP Sybase IQ 时,系统将自动设置 IQDIR16 变量。如果未设置 IQDIR16 变量,则在 iqsrv16 的启动目录中创建 DumpAllThreads 文件。

SAP Sybase IQ 服务器将检测 DumpAllThreads 文件是否存在,并在堆栈跟踪文件 stktrc-YYYYMMDD-HHNNSS_#.iq 中写入每个 IQ 线程的堆栈跟踪信息。堆栈 跟踪信息写入堆栈跟踪文件之后,将删除 DumpAllThreads 文件。

SAP Sybase 技术支持部门可使用此堆栈跟踪信息帮助您诊断问题。

• 如果可以连接到数据库,请以十秒为间隔在持续十分钟内对主缓冲区高速缓存和 临时(专用)缓冲区高速缓存运行 IQ UTILITIES 缓冲区高速缓存监控器:

1. 连接到数据库或使用现有连接。

2. CREATE TABLE #dummy_monitor(c1 INT);

3. IQ UTILITIES MAIN INTO #dummy_monitor START MONITOR '- append -debug -interval 10 -file_suffix iqdbgmon';


4. IQ UTILITIES PRIVATE INTO #dummy_monitor START MONITOR '- append -debug -interval 10 -file_suffix iqdbgmon'; 让该进程运行 10 分钟,然后停止缓冲区高速缓存监控器:

5. IQ UTILITIES MAIN INTO #dummy_monitor STOP MONITOR;

6. IQ UTILITIES PRIVATE INTO #dummy_monitor STOP MONITOR;

• 检查靠近 SAP Sybase IQ 消息文件的末尾处是否存在消息 Resource count 0, 其后面可能跟有 Open Cursor 消息。这些消息表示资源耗尽,这可能导致死锁。 直接解决方案是使用 Ctrl+C 或 DROP CONNECTION 命令减少活动连接数。 避免由于资源耗尽而导致死锁的长期解决方案是以下一种方案或几种方案的组合:

• 通过减少 -gm 服务器启动选项的值来限制服务器的用户数

• 将另一台辅助服务器添加到 Multiplex

• 通过添加 CPU 来增加硬件的处理容量




--------------------------------------华丽的分割线-------------------------------------------------------------------------

Sybase SQL Anywhere数据库恢复工具ReadASADB:

之前就已经研发成功了能够从Sybase SQL Anywhere的DB文件中恢复数据的工具: ReadASADB。
此工具支持ASA v5.0, v6.0, v7.0, v8.0, v9.0, v10.0, v11.0, v12.0, v16.0, v17.0等版本。
能够从损坏的SQL Anywhere数据文件(.db)和UltraLite数据文件(.udb)上提取数据的非常规恢复工具。
恢复Sybase SQL Anywhere的工具在国内处于领先水平。

Sybase SQL Anywhere数据库恢复工具ReadASADB功能
能够从损坏的SQL Anywhere数据文件(.db)和UltraLite数据文件(.udb)上提取数据的非常规恢复工具
  1. 适用于所有的SQL Anywhere版本    包括:5.x,6.x,7.x,8.x,9.x,10.x,11.x,12.x,16.x,17.x
  2. 适用于所有的UltraLite版本
  3. 能够恢复出来表结构和数据
  4. 能够恢复自定义数据类型
  5. 能够恢复存储过程等对象的语法
  6. 能够导出到目标数据库
  7. 能够导出到SQL文件并生成导入脚本
  8. 支持多种字符集,包括:cp850、cp936、gb18030、utf8等
  9. 能够恢复未加密或者简单加密类型的数据
  10. 简单易用
  11. 限制:不支持AES加密的数据文件
请参考:研发成功了从Sybase SQL Anywhere的DB文件上恢复数据的工具
            SQL Anywhere数据库非常规恢复工具ReadASADB使用介绍

Sybase SQL Anywhere数据库恢复工具ReadASADB适用场景

各种误操作:

  1. 误截断表(truncate table)
  2. 误删除表(drop table)
  3. 错误的where条件误删数据
  4. 误删除db或log文件
  5. 误删除表中的字段

Sybase SQL Anywhere数据库恢复工具ReadASADB的应用场景:

1.因为物理磁盘故障、操作系统、系统软件方面或者掉电等等原因导致的Sybase SQL Anywhere数据库无法打开的情况;
2.误操作,包括truncate table,drop table,不正确的where条件导致的误删除等;
Sybase SQL Anywhere无法打开时,比较常见的错误是:Assertion failed。
如:
1、Internal database error *** ERROR *** Assertion failed:201819 (8.0.1.2600) Checkpoint log: invalid bitmap page -- transaction rolled back
2、Internal database error *** ERROR *** Assertion failed:201819 (8.0.1.2600) Page number on page does not match page requested -- transaction rolled back
3、Internal database error *** ERROR *** Assertion failed:200502 (9.0.2.2451) Checksum failure on page 23 -- transaction rolled back
4、File is shorter than expected
5、Internal database error *** ERROR *** Assertion failed: 201116 Invalid free list index page found while processing checkpoint log -- transaction rolled back
6、*** ERROR *** Assertion failed: 51901 Page for requested record not a table page or record not present on page
7、*** ERROR *** Assertion failed: 201417 (7.0.4.3541) Invalid count or free space offset detected on a table page
8、Internal database error *** ERROR *** Assertion failed: 201425 (8.0.3.5594) Invalid count or free space offset detected on a free list page -- transaction rolled back.
9、Internal database error *** ERROR *** Assertion failed: 100702 (8.0.1.2600) Unable to modify indexes for a row referenced in rollback log -- transaction rolled back


-------------------------------------------------------------------------------------------

Sybase ASE数据库恢复工具READSYBDEVICE:

一个不依赖数据库管理系统、直接从Sybase数据库设备文件上提取数据的业内领先的恢复工具!
能够从损坏的Sybase ASE设备文件(.dat)上提取数据的非常规恢复工具。

Sybase ASE数据库恢复工具READSYBDEVICE的主要功能:

  1. 被勒索病毒加密数据文件及备份文件情况下的恢复;
  2. 系统崩溃只剩下数据文件的情况下的恢复,甚至数据库文件不存在而只有损坏的备份文件情况下的恢复;
  3. 因断电、硬盘坏道等造成数据库文件损坏情况下的恢复;
  4. delete数据恢复、误update数据恢复、误删除表(drop)恢复、误truncate表恢复 等;
  5. 各种Sybase内部系统表损坏、索引错误的修复;
  6. master数据库损坏而无法正常运行情况下的恢复;
  7. Sybase数据库被标记为可疑,不可用等情况的恢复;
  8. Sybase数据库中数据文件内部出现坏块情况下的恢复;
  9. Sybase数据库无数据文件但有日志文件的情况下的恢复;
  10. Sybase数据库只有数据文件无任何日志文件的情况下的恢复;
  11. Sybase数据文件被误删除情况下的碎片提取恢复;
  12. 磁盘阵列上的Sybase数据库被误格式化情况下的数据库恢复;
  13. 数据库sysobjects等系统表损坏无法正常应用情况下的恢复;
  14. Sybase数据库还原数据库出现失败情况下的恢复;
  15. Sybase数据库只剩下损坏的备份文件情况下的恢复。

Sybase ASE数据库恢复工具READSYBDEVICE支持的版本:

Sybase ASE 11.0.x,11.5.x,11.9.x,12.0.x,12.5.x,15.0.x,15.5.x,15.7.x,16.0.x


-------------------------------------------------------------------------------------------

SQL Server数据库恢复工具SQLRescue:

一个不依赖数据库管理系统、直接从SQL Server数据库文件上提取数据的业内领先的恢复工具!
能够从损坏的SQL Server数据库文件(.mdf)上提取数据的非常规恢复工具。

SQL Server数据库恢复工具SQLRescue的主要功能:

  1. 系统崩溃只剩下数据文件的情况下的恢复,即无日志文件或者日志文件损坏情况下的恢复;
  2. 断电导致数据库文件损坏情况下的恢复;
  3. 硬盘坏道造成数据库损坏情况下的恢复;
  4. 数据文件内部存在坏页情况下的恢复;
  5. 企业管理器误删除数据表记录,管理软件误删除数据表记录的恢复;
  6. 并闩锁错误、格式化、误删除后导致软件不能使用的情况;
  7. 无法读取并闩锁页sysindexes失败情况下的修复;
  8. 数据文件被误删除情况下的碎片提取恢复;
  9. 系统表损坏、索引错误、误删除数据库表、删除记录的数据找回;
  10. master数据库损坏而无法正常运行情况下的恢复;
  11. 数据文件无法附加情况下的数据恢复;
  12. 数据库被标记为可疑,质疑,不可用等情况的恢复;
  13. 数据库sysobjects等系统表损坏情况下的恢复;
  14. 数据被误(drop、delete、truncate)删除表数据的恢复,误update后的数据恢复等;
  15. 还原时报一致性错误,错误823等情况下的数据恢复,各种错误提示的数据库文件修复;
  16. 数据库被误格式化等情况下的数据库恢复;
  17. 日志收缩造成数据库损坏情况下的恢复;
  18. 仅剩损坏的备份文件情况下的恢复。

SQL Server数据库恢复工具SQLRescue技术特点:

只要SQL Server数据库的数据文件存在,我们就有办法帮您从数据文件中找回重要数据。
  1. 从数据文件中直接恢复数据
  2. 不能附加时直接恢复数据并生成新的数据库
  3. 系统表损坏的数据库修复
  4. 快速修复SQL 823错误、连接中断错误

SQL Server数据库恢复工具SQLRescue支持的版本:

Microsoft SQL Server 7.0, 2000, 2005, 2008, 2008R2, 2012, 2014, 2016, 2017,2019。
+-------------------------------------华丽的分割线-------------------------------------------------------------------------