Linux 5下安装oracle开始遇见的错误 缺少包libXp-1.0.0-8.i386.rpm

在运行./runInstaller时出现的错误

错误一:

/tmp/OraInstall2007-12-30_02-16-11PM/jre/1.4.2/lib/i386/libawt.so: libXp.so.6: cannot open  shared object file: No such file or directory occurred.

原因是:缺少支持打印的图形化动态链接库libXp.so.6

这个错误是由于缺少系统安装包,在RHEL5以前的版本,可以安装xorg-x11-deprecated-libs包即可,这个安装包可以在系统光盘第三张盘中找到(对于redhat as4.2以前,redhat as4.4是在第四张安装光盘)

我下载的文件如下:

xorg-x11-deprecated-libs-6.8.2-31.i386.rpm

 

我用的是redhat 5,在5中 被libXp-1.0.0-8.i386.rpm替代了,所以从安装盘中找到这个文件,

rpm  -Uvh   libXp-1.0.0-8.i386.rpm

再./runInstaller就没有问题,可以启动图形界面了。

转自:http://shuhui018125.blog.163.com/blog/static/7711050201062203346193/

  • 本文链接地址:http://www.dbainfo.net/oracle10g-linux5_4-installer-libxp.htm
  • 本文为dbainfo个人原创,请在尊重作者劳动成果的前提下进行转载;
  • 转载务必注明原始出处 : Sybase数据库技术,数据库恢复专家
  • 对《Linux 5下安装oracle开始遇见的错误 缺少包libXp-1.0.0-8.i386.rpm》有何疑问或见解,请在本文下方发表;
  • 对网站还有其他问题或建议,请提交在留言板,谢谢!
  • 目前还没有任何评论.
    :wink: :twisted: :roll: :oops: :mrgreen: :lol: :idea: :evil: :cry: :arrow: :?: :-| :-x :-o :-P :-D :-? :) :( :!: 8-O 8)